LE MONDE DU DIAGNOSTIC AUTO
Bienvenue sur le forum "Le monde du diag auto".

Afin de profiter pleinement de tout ce que vous offre notre forum, merci de vous présentez, si vous êtes déjà membre ou de rejoindre notre communauté si vous ne l'êtes pas encore.

LE MONDE DU DIAGNOSTIC AUTO

Diagnostic et Mécanique Automobile.
 
Accueil  FAQ  Rechercher  S'enregistrer  Connexion  
Présentation simplifiée et obligatoire pour avoir accès au forum
Hebergeur d'image
Derniers sujets
» Def 079 (P0638) le retour
par Quentin94 Hier à 19:53

» Présentation de Cédric
par drix92 Hier à 19:48

» Remplacement FAP sur scenic 2 phase 2
par Alliottom59 Hier à 19:09

» divers défauts suite diag
par claude.n Hier à 18:17

» Présentation de Jérôme
par gero974 Hier à 18:15

» Présentation de rémy
par nicoyo72 Hier à 16:59

» Présentation de zacharie
par zacharie Hier à 15:51

» 407 HDI 136 ( 2006 ) remplissage additif ( cerine )
par fred33 Hier à 15:46

» Présentation de thierry
par fred9545 Hier à 13:13

» Présentation de Emmanuel
par fred9545 Hier à 10:54

» Présentation de dominique
par fred9545 Hier à 9:55

» probleme moteur turbo
par raf94 Hier à 9:13

» Porte AV Droite bloquée Audi A4 B8
par FloOoW Hier à 7:51

» Présentation de Tiago
par fred9545 Hier à 1:11

» Présentation de Benoit
par heineken 19.06.18 22:30

» Présentation de David
par heineken 19.06.18 22:29

» Présentation de jean
par heineken 19.06.18 22:28

» Présentation de fabrice
par heineken 19.06.18 22:26

» Présentation de ludo
par heineken 19.06.18 22:26

» Panne faisceau .
par oliveur33 19.06.18 21:02

» moteur ne demarre plus
par Fbinbin 19.06.18 19:49

» Pb activation diagbox
par aigle459141 19.06.18 18:18

» Cherche conseil pour ODB compatible véhicules japonais.
par pjmdur 19.06.18 15:15

» Probleme de démarrage + bug megane II 1.9dci 120ch
par heineken 19.06.18 14:57

» déconnexion can clip
par hpvectravl 19.06.18 14:36

» Message d'erreur Acti-Diag
par loren3372 19.06.18 12:55

» Présentation de jimmy
par mano800 19.06.18 1:59

» Présentation de alvaro
par heineken 18.06.18 22:43

» Présentation de sebastien
par heineken 18.06.18 22:40

» Présentation de sebastien
par heineken 18.06.18 22:36

» Présentation de gilles
par heineken 18.06.18 22:34

» remettre a zéro ,le service vidange et le service inspection A3 TFSI 2016
par lepins 18.06.18 19:49

» C8 problème d'airbag
par Jp59 18.06.18 16:24

» probleme avec electrovannes egr et turbo
par angel 18.06.18 15:04

» Présentation de Nicolas
par snip 18.06.18 14:03

» X5 e53.Calculateur ABS communication impossible.
par Valériedu52 18.06.18 12:57

» 5008 2.0 hdi 163 bva6 code defaut p0131
par rachrbx 18.06.18 12:32

» Présentation de Ericardo
par fred9545 18.06.18 11:49

» Présentation
par fred9545 18.06.18 11:48

» Présentation de Jacky
par fred9545 18.06.18 11:47

Qui est en ligne ?
Il y a en tout 38 utilisateurs en ligne :: 8 Enregistrés, 0 Invisible et 30 Invités :: 2 Moteurs de recherche

aioli, blackpearlfr, ddlembrouille, Jp59, Mka, papinjoe, Valériedu52, watso

Le record du nombre d'utilisateurs en ligne est de 335 le 25.03.18 17:23
Membres les plus tagués
@Alliottom59 (110)
 
@heineken (83)
 
@popeye05 (59)
 
@fred9545 (49)
 
@Digidid (34)
 
@Alexlesinge (33)
 
@jeremy72 (26)
 
@fandf (25)
 
@scorpium59 (23)
 
@Euzen (22)
 
Partagez | .
 

 P1640 Asta G

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: P1640 Asta G   04.01.15 11:10

Bonjour! Grace a ce forum j'ai pu utiliser Scanmaster sur mon Astra pour voyant moteur allumé et le code défaut relevé est P1640, Module Quad "A".
Qu'est-ce que le module quad? Quels controles dois-je effectuer? Merci d'avance.
PS : Le véhicule est donc une Astra G de fin 1999, 1.6 essence X16SZR
Revenir en haut Aller en bas
Alliottom59
Fondateur et Admin
Fondateur et Admin
avatar

Messages : 15609
Date d'inscription : 08/12/2012
Age : 36
Localisation : Maubeuge sous le parapluie mais les fesses au chaud

MessageSujet: Re: P1640 Asta G   04.01.15 11:31

Bonjour,

il démarre ce véhicule ?

_________________
Tous comptes ne respectant pas les règles de présentation seront remis a "0".
La carte des membres est disponible ci-dessous.

[Vous devez être inscrit et connecté pour voir ce lien]

Je ne réponds pas aux demandes d'aide ou code en MP.  [Vous devez être inscrit et connecté pour voir cette image]

Vous approuvez une réponse dans un sujet ?
Alors faite le savoir en cliquant sur la main verte.
Revenir en haut Aller en bas
http://www.lemondedudiagauto.com
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   04.01.15 11:51

Oui et tourne bien. Au debut le voyant s'allumait de temps en temps de façin aléatoire et restait plus ou moins longtemps. Jusqu'au jour ou il s'est allumé et plus jamais éteind. J'avais pensé à la sonde lambda avant de brancher l'ordi vu que sur essence c'est courant
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: P1640 Asta G   04.01.15 12:25

Bonjour à tous!! cheers  
Voici une définition en anglais du code P1640 si cela peut aider:


A+.
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   04.01.15 12:30

Dac merci piem mais comment interpréter ça?
Revenir en haut Aller en bas
pilloui57
Apprenti
Apprenti
avatar

Messages : 108
Date d'inscription : 22/03/2013
Age : 21
Localisation : Angoulins

MessageSujet: Re: P1640 Asta G   04.01.15 12:33

bonjour et bonne année

p1640 chez Opel signifie Quad Driver Module Erreur A ou B. En cherchant un peu, la traduction équivaut à ça : L'ECM utilise "des conducteurs quadruples" pour contrôler ses dispositifs de sortie. Chaque conducteur quadruple est capable de direction jusqu'à quatre dispositifs.
Certains résolvent le problème en changeant l'ECM (Pas sur du résultat), le mieux est de chercher dans le faisceau s'il y a coupure ou s'il y a un élément de défectueux.
Le conducteur quadruple incriminé "A" en l’occurrence sur votre voiture alimente ces différents organes que l'on peut voir sur l'image ci-dessous ( c'est en anglais mais pas très compliqué à traduire)

[img][Vous devez être inscrit et connecté pour voir cette image][/img]

J'espère vous avoir aidé un peu pour l'explication de ce défaut.


_________________
Je connais pleins de choses et je dois tout à mon père mais je veux encore apprendre
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   04.01.15 12:36

Dac merci donc je dois contrôler du côté du canister et du circuit de refroidissement alors vu que je n'ai pas d'EGR me semble t il
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   05.01.15 16:37

J'ai téléchargé a.u.t.o.d.a.t.a pour m'aider, il y a en effet une vanne EGR que je n'ai pu contrôler car pas d'outils chez moi je le ferais ce week end.
J'ai donc contrôlé l'électrovanne de canister qui est ok, ce week end je m'attele à l'EGR et au refroidissement d'après le schéma de pilloui
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   11.01.15 16:18

Bonjour bonjour! Pour les News, j'ai contrôlé sonde lambda, EGR, électrovanne canister, sonde temperature d'eau et j'en oublie sûrement et il se trouve que ce SERAIT la sonde de temperature.
J'explique : entre 2 bornes de la broche du calculateur moteur je devais trouver entre 1,9 et 2,3V suivant la temperature du liquide et il se trouve que je n'ai pas pu prendre la mesure (elle restait à 0 ou oscillait légèrement 0,1-0,2).
En y repensant c'est vrai que la jauge du tableau de bord est bizarre puisqu'elle reste en bas et seulement quand je suis dans les bouchons elle monte doucement jusqu'au 90, mais réagis quand le ventilo s'enclenche puisque la temperature baisse. Mais si je repart en roulant bien elle redescend à 0.
Qu'en pensez vous sonde HS? Serait-elle la cause de mon voyant? Merci d'avance
Revenir en haut Aller en bas
biggugus
Apprenti
Apprenti
avatar

Messages : 225
Date d'inscription : 06/10/2014
Age : 54
Localisation : A droite après les 2 vaches.

MessageSujet: Re: P1640 Asta G   11.01.15 17:53

Sur opel la temperature du calculateur et du tableau de bord sont prise par deux sonde différentes.
Par contre ton problème de température qui ne monte que dans les bouchons c'est signe d'un calorstat bloqué ouvert.
Rien a voir avec ton problème électronique mais sur que ton calorstat a un souci.
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   11.01.15 17:55

Pourtant meme en plein hiver le chauffage vient rapidement..?
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   11.01.15 20:25

Et puis meme, j'aurai du avoir des valeurs sur la broche du calculateur. J'ai fais un test à froid et un test à 90degrés et rien donc j'en ai déduis que la sonde qui donne l'info au calculo était défectueuse.
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   03.03.15 18:35

Re bonjour, je reviens vers vous car je n,'ai toujours pas résolu mon probleme ne sachant pas d,où il vient... Par rapport au schéma j'ai controlé l'EGR au multimetre qui est bon, l'electrovanne de canister pareil, coolant fan relay je crois que c'est le relais des ventilos mais le ventilo déclanche donc je pense pas qu'il y ait un soucis et service engine soon light ce doit etre le voyant moteur au tableau de bord. Quelqu'un aurait une piste pour m'éclairer? Merci d'avance je désespere
Revenir en haut Aller en bas
ulysse79
Pilier PSA
Pilier PSA
avatar

Messages : 2819
Date d'inscription : 25/10/2013
Age : 45
Localisation : poitou-charente

MessageSujet: Re: P1640 Asta G   03.03.15 19:54

hello ,

le principal c'est que ta voiture roule , as-tu changer la sonde tempé du LDR ?

_________________
[Vous devez être inscrit et connecté pour voir cette image]...... pour dire merci a un membre , clic sur la main verte ... [Vous devez être inscrit et connecté pour voir cette image]  .........    [Vous devez être inscrit et connecté pour voir cette image]
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   03.03.15 19:58

Oui elle roule et ça ne me pose pas de problemes, le soucis est que je veux la vendre et que le voyant freine les acheteurs... La sonde non, je ne l'ai pas remplacée
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   08.03.15 17:58

Salut, j'ai changé la sonde aujourd'hui, contrôlé tout ce qui est relais mais toujours pareil.... La' je n'ai plus de pistes. Un petit coup de main?
Revenir en haut Aller en bas
toto65
Novice
Novice
avatar

Messages : 32
Date d'inscription : 03/01/2015

MessageSujet: Re: P1640 Asta G   17.03.15 11:17

Bonjour, je sais pas si il y a un rapport mais aujourd'hui je roulais en 2nde à 30-35 km/h et la voiture à calé, impossible de redémarrer. J'ai du attendre 15-20sec avant de pouvoir redémarrer en insistant un peu sur le démarreur....
Revenir en haut Aller en bas
 

P1640 Asta G

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
LE MONDE DU DIAGNOSTIC AUTO  :: Opel :: Opel :: Diagnostic Opel-